centos多版本php配置多版本composer

php项目在实际使用中,往往有些项目需要依赖不同版本的composer,每次切换版本会比较麻烦。这里记录配置多composer的方法,方便日后查看及开发者参考。


说明

PHP多个版本编译安装在以下目录,类同。

/usr/local/php/php5.6.29/
/usr/local/php/php7.2.4/

这里使用php7及5.6作为示例参考,其他版本均参考此方法均可。

cd /usr/local/php/php7.2.4/bin/
curl -sS https://getcomposer.org/installer | ./php

cd /usr/local/php/php5.6.29/bin/
curl -sS https://getcomposer.org/installer | ./php

配置启动文件

# 对应版本 php7

vi /usr/local/bin/composer7

#!/bin/bash
export PATH=$PATH:/usr/local/php/php7.2.4/bin/
php /usr/local/php/php7.2.4/bin/composer.phar $*

# 对应版本 php5.6 (默认)

vi /usr/local/bin/composer

#!/bin/bash
export PATH=$PATH:/usr/local/php/php5.6.29/bin/
php /usr/local/php/php5.6.29/bin/composer.phar $*

运行权限

chmod +x /usr/local/bin/composer7
chmod +x /usr/local/bin/composer

运行示例

配置中国镜像

composer7 config -g repo.packagist composer https://packagist.phpcomposer.com
composer config -g repo.packagist composer https://packagist.phpcomposer.com

查看 composer 版本

composer7 -V
composer -V

本文链接:

http://xueyuphp.cn/index.php/archives/29/
1 + 4 =
0 评论